LinuxGuruz

Title:       Using both PHP 3.x and PHP 4.x Instalation Notes
Contributor: Randall Goguen (aka Ranman)
Last Update: Tuesday May 9 20:57 EST 2000

# Configure the PHP3 and PHP4 sources with:
#
 ./configure \
 --with-apxs=/usr/local/apache/bin/apxs \
 --enable-versioning

# Here is a snipit of LoadModule lines from a httpd.conf file:
#
LoadModule php3_module        libexec/libphp3.so
LoadModule php4_module        libexec/libphp4.so

# Here is a snipit of AddModule lines from httpd.conf file:
#
AddModule mod_php3.c
AddModule mod_php4.c

# Here is a snipit of DirectoryIndex lines from httpd.conf file:
#
<IfModule mod_dir.c>
    DirectoryIndex index.html index.htm index.php index.php3
</IfModule>

# Here is a snipit of AddType lines from httpd.conf file:
#
<IfModule mod_php3.c>
AddType application/x-httpd-php3 .php3
AddType application/x-httpd-php-source3 .phps
</IfModule>
<IfModule mod_php4.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
</IfModule>


        Anyone who wishes to make additions or changes to this
PHP Tip email them to webmaster@linuxguruz.org

        This document is Copyright (c) 1999, 2000, 2001, 2002 by LinuxGuruz